Mettre Waterfox Current-G3 en Français

Publié le par Wullfk

Mettre Waterfox Current-G3 en Français

Waterfox Classic étant chez moi de plus en plus lent (freeze/lag), j'ai décidé de tester Waterfox Current conjointement à Waterfox Classic.

Waterfox Current 2020.10 (dernière en date) est basé sur Firefox ESR 68

L'installation s'effectue dans un dossier indépendant.

Dossier d'installation de Waterfox
Dossier d'installation de Waterfox

Par contre, il utilise le même dossier de profil que Waterfox Classic.

Une fois installé la première chose à effectuer c'est de le mettre en Français, mais là impossible dans les options d'ajouter la langue, ça indique de vérifier la connexion Internet ??? Alors que je suis bien connecté.


À ce stade, j'avoue ne pas bien comprendre d’où vient le problème.

Une recherche sur Waterfox Community Support ne m'apporte pas plus de réponse et de solution.

Pire, une solution proposée sur GitHub : impossible to install the French language

préconise de télécharger le package de langue de Firefox, sauf qu'une fois installé, on peut effectivement choisir le Français dans les options, mais pour qu'elle soit prise en compte il faut redémarrer le navigateur, et là catastrophe Waterfox Current ne démarre plus !!!

Seule solution, la désinstallation du navigateur en prenant soin de désinstaller uniquement ce qui correspond à Waterfox Current, pour cela j'utilise l'utilitaire RevoUninstaller.

J'ai fini par trouver la solution, mais elle n'est pas évidente, et n'est pas à la porté d'utilisateurs lambda.

J'en déduis que cette version n'est pas encore aboutie pour les pays autres qu'Anglophones.

Pour ceux que ça intéresse et leur éviter d'avoir à décompresser un package tar.zst prévu pour ArchLinux (7zip et WinRar ne prennent pas en charge ce format) je met à disposition à la fin de cet article une archive contenant le fichier : langpack-fr-waterfox-current.xpi améliorée, car dans la version source la traduction n'est pas complète.

Après il suffit d'installer le fichier .xpi en manuel dans Waterfox Current.

Ne vous étonnez pas si vous obtenez ceci :

Dans l'onglet Modules, en l'état on ne peut rien y faire.

Pour une autre langue, télécharger le paquet ArchLinux correspondant à votre langue ici :

https://download.opensuse.org/repositories/home:/hawkeye116477:/waterfox/Arch/x86_64/

Pour extraire le fichier .xpi il faut utiliser l'utilitaire Peazip ou Bandizip

  • La procédure complète

Extraire une première fois le fichier waterfox-current-i18n-fr-2020.07.1-0-x86_64.pkg.tar.zst avec Peazip ou Bandizip

Pour obtenir le fichier waterfox-current-i18n-fr-2020.07.1-0-x86_64.pkg.tar

Extraire une deuxième fois pour avoir le dossier :

waterfox-current-i18n-fr-2020.07.1-0-x86_64.pkg

dans l'arborescence de dossiers usr/lib/waterfox-current/browser/extension/

on à langpack-fr@waterfox-current.xpi

ATTENTION ! ce fichier .xpi ne fonctionne pas pour Waterfox G3 cette 3ᵉ génération de Waterfox est basé sur Firefox ESR 78

Pour la version G3 il faut prendre le fichier langpack-fr@l10n.waterfox.net.xpi extrait de l'archive waterfox-g3-i18n-fr-0.2-1-x86_64.pkg.tar.zst en suivant la procédure précédemment fournie.

Waterfox G3.1.0 est sortie, il est basé sur  Firefox ESR 78.7

sauf que l'ancien "patch Fr" ne fonctionne plus et plante le lancement de Waterfox, on obtient l'erreur suivante, quel que soit le profil :

Erreur lancement Waterfox G3
Erreur lancement Waterfox G3

Solution : faire "Exécuter", puis "waterfox -safe-mode", choisir le profil et désinstaller le pack lang FR.

Ou plus radical, désinstaller Waterfox.

Il faut à présent récupérer le package suivant : waterfox-g3-i18n-fr-1.0-0-x86_64.pkg.tar.zst

et toujours suivre la même procédure d'extraction pour récupérer le fichier .xpi, il porte le même nom (langpack-fr@l10n.waterfox.net.xpi) que celui qui fonctionnait sur la précédente version de Waterfox G3

Ou sinon télécharger directement le Pack Langue fr pour Waterfox G3.1.0  (contient le fichier .xpi) que j'ai mis à disposition ci-dessous.

24/02/2021 Waterfox G3.1.1 est sortie, il est basé sur  Firefox ESR 78.8

Pack Langue fr pour Waterfox G3.1.1 disponible ci-dessous.

Pack Fr pour Waterfox G3.1.1

Pack Fr pour Waterfox G3.1.0

Pack Fr pour Waterfox Current

Publié dans Navigateur

Commenter cet article

Rodolphe 24/02/2021 19:15

Merci pour cet article très pratique.
En effet c'est bien chiant de devoir remettre l'extension en français après chaque mise à jour.
Pour info, lorsque le bug apparaît au lancement, pas la peine de désinstaller complètement Waterfox, il suffit de faire "Éxecuter", puis "waterfox -safe-mode", choisir le profil et désinstaller le pack lang FR.

Wullfk 24/02/2021 23:26

Merci pour l'info, j'ai mis à jour l'article avec la procédure pour le lancement en safe mode

François 10/02/2021 06:50

Grand merci pour la mise à jour du fichier !

JJ 05/02/2021 17:26

Bonjour,
Le fichier "langpack-fr@l10n.waterfox.net.xpi " ne fonctionne pas/plus avec la version G 3.1.0

Wullfk 06/02/2021 13:07

J'ai mis à jour mon article, avec le package Fr qui fonctionne sur la version G3.1.0
C'est quand même bien chiant de devoir aller à la pêche au package à chaque nouvelle version de Waterfox G3

Wullfk 05/02/2021 18:02

Bonsoir,

Je sais, et cela m'a mis en colère, voir mon post sur le support de Waterfox : https://www.reddit.com/r/waterfox/comments/lbalk9/i_abandoned_waterfox_and_went_back_to_firefox/

Albert nosbeu 23/11/2020 17:12

Wullfk a écrit : Je vous ai moi même fourni ce lien.

Oui je sais , et je vous en remercie.

Bonne journée.

Albert nosbeu 21/11/2020 11:46

Merci pour la réponse rapide , effectivement pour la version Waterfox Current 20.10 cela fonctionne parfaitement bien.

Mais pour la dernière version Waterfox Current G3.0.0.1 , cette méthode malheureusement ne fonctionne plus.

Bien a vous.

Wullfk 22/11/2020 13:22

Je vous ai moi même fourni ce lien

Albert nosbeu 22/11/2020 08:59

Pour Waterfox Current G3.0.0.1 ça fonctionneavec ce lien :

https://raw.githubusercontent.com/MrAlex94/Waterfox/future/browser/extensions/langpack-fr%40l10n.waterfox.net.xpi

Wullfk 21/11/2020 14:14

c'est tout à fait normale que ça ne fonctionne pas puisque Waterfox Current 2020.10 est basé sur Firefox ESR 68, alors que Waterfox Current G3.0.0.1 est basé sur Firefox ESR 78. Je vais voir si je trouve le fichier xpi correspondant, dans ce cas je le mettrait en ligne à la fin de l'article. En attendant vous pouvez utiliser la version Current 2020.10 en désactivant la mise à jour automatique.