Installer des add-ons non signés sous Firefox 48

Publié le par Wullfk

Installer des add-ons non signés sous Firefox 48

Installer des add-ons non signés sous Firefox 48

Bonjour,

Depuis la version Firefox 48.0 Mozilla a renforcé la protection pour vous empêcher d'installer des add-ons non signé.

L'ancienne manip qui consistait à modifier dans about:config la clé xpinstall.signatures.required en la passant à false ne suffit plus.

Sylvain (administrateur du site Tutoriaux-Excalibur) à trouvé la parade

Avec cette astuces ou contournement celons certains vous pourrez installer dorénavant n'importe quel add-ons non signé

Initialement l'astuce à été réalisé pour pouvoir installer la barre d'outils Google Toolbar.

Voir : Installer un module non signé comme Google Toolbar sous Firefox 48 et plus

  cette manipulation est à faire en ayant pleinement conscience que cela va à l'encontre de toutes notions de sécurité..

Préalablement il faut installer un patch dans Firefox

Téléchargement du Patch Firefox (archive ZIP) : Patch Firefox.zip

Note: toutes les captures d'écrans proviennent de Tutoriaux-Excalibur

1/ Une fois l'extraction réalisé, le patch est composé de deux fichiers

  • config.js
  • config-pref.js

Note: Vous pouvez ouvrir les fichiers JS avec le bloc-notes pour vérifier le contenu du code

2/ Avec l'explorateur de Windows, naviguez vers ce répertoire:

C:\Program Files (x86)\Mozilla Firefox\defaults\pref

3/ Copier/Coller le fichier config-pref.js dans ce répertoire

4/ Naviguez maintenant vers le répertoire:

C:\Program Files (x86)\Mozilla Firefox

Copier / Coller le fichier config.js dans ce répertoire

5/ À présent ouvrez about:config

6/ Si ça n'a pas été déjà fait depuis Firefox 43.0, faites un double clic sur la clé suivante afin qu'elle puissent être désactivées (false) au lieu de (true)

  • xpinstall.signatures.required

Optionnel: passer c'est deux clés à false dans le cas ou la première modification ne fonctionnerait pas.

  • xpinstall.whitelist.required
  • services.sync.prefs.sync.xpinstall.whitelist.required

Attention, si vous passez xpinstall.whitelist.required à false, vous ne serez plus prévenu lorsque les sites essaient d’installer des modules complémentaires, ce pose alors un vrai problème de sécurité.

Redémarrer Firefox

Vous devez à présent pouvoir installer n'importe quel module d'extension non signé par Mozilla

Téléchargement de Google Toolbar Excalibur : https://1fichier.com/?ve2oxl4dt3

Un grand MERCI à Sylvain

Bonus : En téléchargement une version de CoolPreviews (version 3.5) modifié par Sylvain pour pouvoir fonctionner sur Firefox 48.0 et +

CoolPreviews FF48.zip

Et pour ceux qui souhaitent une version plus récente c'est aussi disponible avec la 4.6

CoolPreviews-4.6.zip

Je vous invite à consulter le tuto suivant pour modifier une extension pour la rendre compatible avec Firefox 48.0 et +

Comment modifier un module pour le faire fonctionner sur toutes les versions Firefox

Pour que l'extension modifiée puisse fonctionner il faut préalablement installer le Patch Firefox

Publié dans Navigateur

Commenter cet article